Problemer ved innlogging
Incident Report for Tekna
Resolved
This incident has been resolved.
Posted Jun 14, 2016 - 09:35 CEST
Investigating
Noen av våre brukere får tidsavbrudd ved innlogging. Vi undersøker saken.
Posted Jun 07, 2016 - 10:58 CEST