tekna.no er nede
Incident Report for Tekna
Resolved
Tekna.no er oppe igjen.
Posted Nov 27, 2019 - 10:40 CET
Investigating
Vi feilsøker.
Posted Nov 27, 2019 - 10:39 CET
This incident affected: tekna.no.