Ikke mulig å endre passord for innlogging
Incident Report for Tekna
Resolved
This incident has been resolved.
Posted Jun 12, 2017 - 14:54 CEST
Investigating
Det er for øyeblikket ikke mulig å endre passord på tekna.no
Posted Jun 12, 2017 - 12:53 CEST