Ustabil drift på tekna.no
Incident Report for Tekna
Resolved
This incident has been resolved.
Posted Apr 29, 2016 - 22:21 CEST
Investigating
Vi undersøker nettverksproblemer
Posted Apr 29, 2016 - 21:53 CEST